Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 20, 2026 - 22:00 CET
Scheduled
We are updating parts of our platform to the latest software versions. You may notice short periods of degraded performance or short unavailability during the maintenance window.
Posted Jan 15, 2026 - 13:05 CET
This scheduled maintenance affected: [EU] Web Application, [EU] Mobile App, [EU] PDF Processing, and [EU] Image Processing.